Troubleshooting the installation

Incase you run into issues while installing Ariv into your own workspace, the following information will help.

Ariv is currently in beta, therefore only workspace owners or administrators can install Ariv. If you are not the workspace owner or do not have administrative privileges for the workspace please ask your workspace owner or administrator to install the app on your behalf.

Not authorized to install Ariv

This is probably the message that brought you here.

If you got this message when you clicked on the Ariv installation link that was sent to you, then it is very likely that the workspace that you were trying to install ariv on restricts who can install what kind of apps. The only way to install Ariv in such a case, is to ask the workspace administrator or owner to install it for you.

Sorry, but Ariv can't be installed

If you see this message;

Only workspace owners can install ariv in this workspace

This usually means that the workspace that you want to use Ariv in, has a stricter app install policy and only workspace owners can install apps that are not listed on the Slack App Directory. Since Ariv is still in Beta, it is not listed on the Slack App Directory and that leaves you with only one option, ask the workspace owner to install Ariv, using the same link that was sent to you, for you.

How to check your workspace settings

Go to the Settings & administration page for your workspace, and under administration select Manage Apps and if you see the following screen you have the requisite permissions in Slack to install and manage apps.

if you are able to see this page, you will have permissions to manage and install apps in Slack

If the Require App Approval toggle is turned off - then any member of your slack workspace will be able to install apps. Incase its turned on you will have a more granular permission structure for installing apps as shown above 👆